management vrf CMDB nodes

Home Community Forums NetYCE Support tickets (bronze) management vrf CMDB nodes

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #100000452
    Migration User
    Participant

    Hi,

    The following issue exists when running a basic command job, also NCCM fails probably for the same reason.

    Platform: Nexus 9000

    #######

    ls1-lab# copy startup-config sftp://192.168.116.101/public/previous/ls1
    Enter vrf (If no input, current vrf ‘default’ is considered):
    Enter username: ycicle

    ssh: connect to host 192.168.116.101 port 22: No route to host
    Couldn’t read packet: Connection reset by peer

    #######

    Seeing the vrf that should be used is ‘management’ and not the ‘default’ this command fails, can we adjust this behaviour while using CMDB nodes?

    A working solution would be appending the correct vrf to the statement.
    ‘copy startup-config scp://192.168.116.101/public/previous/ls1 vrf management’

    Thanks,
    Jeroen

    #100000453
    Migration User
    Participant

    Hi Jeroen,

    nice talking to you on the phone.

    As mentioned, as a framework we need to be able to work with the/all different possibilities. Since the management VRF is not mandatory to use, the CMDB nodes won’t use this. This doesn’t have any impact on the SSH session. It will impact the (pre/post) backups if the mgmt IP is in another VRF than ‘default’.

    If the nodes are modeled as YCE nodes, the VRF can be linked to the node, where the flag “VRF management” can be enabled. This will alter the backup commands to use the VRF for which management is enabled. This allows you to use other VRF for management than ‘management’ itself as well. This isn’t limited to the Nexus family either.

    If you just wish to communicate with the nodes, without the backups, you may disable those in the state_actions table, under Admin > Custom Data. Please use the following screenshot to accomplish this. (mind the search filters)

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.